Как использовать php в консоли из MAMP

Пользуясь MAMP, вы могли столкнуться с ситуацией, когда php из терминала (консоли) имеет версию ниже той, что используется в MAMP. Например, при вызове composer, тот может ругнуться на несоответствие версии, требуемой пакетом и установленной, хотя у вас в MAMP PHP имеет версию >=7.0.8:


Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - This package requires php >=7.0 but your PHP version (5.6.25) does not satisfy that requirement.
  Problem 2
    - Installation request for includen/money dev-master -> satisfiable by includen/money[dev-master].
    - includen/money dev-master requires php >=7.0 -> your PHP version (5.6.25) does not satisfy that requirement.

Чтобы исправить эту ситуацию и использовать в терминале php из MAMP, добавьте в файл ~/.bash_profile следующий код:


PHP_VERSION=`ls /Applications/MAMP/bin/php/ | sort -n | tail -1`
export PATH=/Applications/MAMP/bin/php/${PHP_VERSION}/bin:$PATH

И перезапустите сеанс терминала.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *